[Mono-dev] Running MCS Tests on Windows

Marek Safar marek.safar at seznam.cz
Mon Jan 18 10:48:12 EST 2010

> I updated to change # 149641, re ran autogen.sh, ran make, make 
> install and tried running the tests again and it still failed.
> I think it might be related to a problem with "make install". Looking 
> back, I remember this happened last time and I overlooked it.
> When I run make install after running make, gmcs throws an exception.
> I attached a debugger, and the problem appears to be inside 
> CodeGen.Init, at the call to DefineDynamicAssembly. It is oring in an 
> extra 0x800 into the access parameter that is passed in.
This indicates you are running Mono C# compiler using Microsoft .NET 
runtime which is not supported.
> I looked into the mono implementation of AssemblyBuilder, and it looks 
> like the flag is being used to signal to AssemblyBuilder that the call 
> is coming from inside the mono c# compiler.
> The problem, however, is that GMCS is binding to the MS implementation 
> of mscorlib, not the mono implementation, and so the extra flag is 
> invalid.
Correct, you are missing mono.exe executable prefix somewhere or your 
gmcs script is broken (pointing to invalid location?).
> In the gmcs source, if MS_COMPATIBLE is defined, the extra value won't 
> be ored in.
> Obviously it's not defined.
> The bug could be either:
> 1. That MS_COMPATIBLE is not set
> 2. Or, that make install is binding to the MS framework implementation 
> and not the mono framework implementation
> I do have mono installed on the machine, and it is included in the 
> cygwin path.
Setting cygwin path is for mono executable and not gmcs.


More information about the Mono-devel-list mailing list