[Mono-dev] Problems with mono continuation

raccoon timo.heubach at gmail.com
Thu Feb 25 03:07:40 EST 2010


I'm trying to use mono continuation on Windows 7, but for some reasong I get
a security exception with this message "ECall methods must be packaged into
a system module.". Anyone else bumped into this? I am experiencing this on
multiple machines running Windows 7.

I suspect that this is because of a missing internal function
"alloc_continuation" (perhaps the others too used for governing
continuations), which I guess the Continuation constructor calls to
initialize the continuation object. I also tried using the microthreading
library made by Tomi Valkeinen (referenced here
http://tirania.org/blog/archive/2009/Apr-09.html), that also uses the
internal call "alloc_continuation" with the same exception. I tried
compiling with Visual Studio 2008 (referencing mono assemblies) and the mono
mcs-compiler with the same results. I also downloaded the mono source code
and looked for a registration of alloc_continuation, but I didn't find it! I
did find something related to continuation in the whole mono VS solution,
but this was just some continuation exception generation for the x86 and
amd64 platforms. It's as if something is missing!

Timo Heubach
Technical Director
Radiant Raccoon
View this message in context: http://n4.nabble.com/Problems-with-mono-continuation-tp1568629p1568629.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list