[Mono-dev] Mono: Issue running xsp on RHEL5

Purnima pkavilkar at melstar.com
Wed Feb 17 11:01:36 EST 2010

Hi Nagappan,


Thanks for your reply.

Steps followed by me:

1.       Previously I had installed the xsp from tar file into the same
'/opt/downloads' folder.

2.       I went into the same folder & executed 'make uninstall' command.

3.       Executed:            ./configure  --prefix /usr/local

4.       Executed:            make

5.       Executed:            make install

6.       After above execution, I came out of all folders using 'cd' &
executed 'xsp' command, it gave me the same error as mentioned in previous

7.       I tried the 'xsp' command by 'cd /usr/local' as well, but no luck.

8.       Should I try Fedora 8, as I have read that it comes with mono
pre-installed in it.



Not understanding as to what is going wrong.

Please help out if you have any guidelines.



Purnima K.



From: Nagappan Alagappan [mailto:nagappan at gmail.com] 
Sent: Wednesday, February 17, 2010 11:41 AM
To: pkavilkar at melstar.com
Cc: mono-devel-list at lists.ximian.com
Subject: Re: [Mono-dev] Mono: Issue running xsp on RHEL5


Hello Purnima,

On Tue, Feb 16, 2010 at 7:37 PM, Purnima <pkavilkar at melstar.com> wrote:



Problem: ASP.NET application not running on mono/xsp not running on Red Hat
Enterprise Linux 5 (RHEL5).


Steps carried out:

1.       I have a system with RHEL5.

2.       I have installed following the same sequence: 

a.       libgdiplus-2.4.2.tar.bz2 

b.      mono-

c.       mod_mono-2.4.2.tar.bz2 

d.      xsp-2.4.2.tar.bz2 

3.       All the above tar files were copied to '/root/opt/downloads'

4.       All of them were untarred & installed in the same above folder.

5.       For testing, I created a Test.cs file & executed using: mcs Test.cs
& mono Test.exe commands, which worked well.

6.       But, when I write 'xsp' command, it gives error: 'bash: xsp:
command not found'

XSP is not installed in PATH.


7.       What am I doing wrong? 

a.       xsp not properly not installed 

b.      mono & other tar files not installed at the path '/usr/local'

c.       Apache/mod_mono needs to be used rather than xsp


Please provide necessary help/guidelines.


Purnima K.

Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com

Linux Desktop (GUI Application) Testing Project -

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20100217/6e4fa408/attachment-0001.html 

More information about the Mono-devel-list mailing list