[Mono-dev] Arm9 NS9215 floating point troubles

jaekim jkim0130 at gmail.com
Fri Aug 13 20:25:21 EDT 2010

I'm having a similar problem.  I'm using a Freescale mc9328mxs processor that
doesn't have hardware floating point.  I've tried Trevor's C# test code and
the console outputs incorrect floating point values.  I have also tried
Trevor's hack to method-to-ir.c and it doesn't help for me. 

                Console.WriteLine("0.0f literal is " + 0.0f);
                Console.WriteLine("1.0f literal is " + 1.0f);
                Console.WriteLine("12.3f literal is " + 12.3f);
                Console.WriteLine("32f literal is " + 32f);
                Console.WriteLine("1024f literal is " + 1024f);
                Console.WriteLine("32768f literal is " + 32768f);

Also when the application exits main(), I get an exception.

Unhandled Exception: System.TypeInitializationException: An exception was
 by the type initializer for System.Runtime.Remoting.Contexts.Context --->
m.ArgumentOutOfRangeException: load factor
Parameter name: loadFactor
  at System.Collections.Hashtable..ctor (Int32 capacity, Single loadFactor,
hCodeProvider hcp, IComparer comparer) [0x00000]
  at System.Collections.Hashtable..ctor (Int32 capacity, Single loadFactor)
  at System.Collections.Hashtable..ctor () [0x00000]
  at System.Runtime.Remoting.Contexts.Context..cctor () [0x00000]

I've spent days trying to figure this out.  Any help is appreciated.

View this message in context: http://mono.1490590.n4.nabble.com/Arm9-NS9215-floating-point-troubles-tp2259090p2324899.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list