[Mono-dev] BasicHttpBinding issues

Matthew Fanto mfanto at gmail.com
Thu Aug 12 02:17:37 EDT 2010

On Thu, Aug 12, 2010 at 2:06 AM, Atsushi Eno <
atsushieno at veritas-vos-liberabit.com> wrote:

> I have no idea on from which this list addition occurs. This might not
> happen in the latest git head or daily builds (but I doubt that). If you can
> provide the runnable example code, I can test it on the latest code.

I might have been quick with my initial email before checking everything. I
also apologize for being vague on details, but everytime it ran, I had
different results. Nothing was predictable.

I've played with this down further and it seems to be caused by Mono Tools
for Visual Studio. If I run the application from cmd.exe with "mono.exe
test.exe", the WCF service listens, and responds to requests as it should.

If I run from within Visual Studio, I am unable to get anything to run.

If I use "Run in Mono", I get an error that the assembly is too large. Using
"Debug in Mono", sometimes the service starts but rejects any request. Other
times, the application crashes with unhandled exceptions.

Also, if I kill the debugger, mono.exe still hangs and does not terminate. I
have to manually terminate it.

cmd.exe runs as the same privileges as Visual Studio.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20100812/c85c86bb/attachment.html 

More information about the Mono-devel-list mailing list