[Mono-dev] BasicHttpBinding issues

Matthew Fanto mfanto at gmail.com
Wed Aug 11 23:21:18 EDT 2010

Forgive me if this is the wrong list. I checked the descriptions of the
various lists, and this one seemed to be the most relevant, as I'm seeing a
difference between running under .NET 3.5 and Mono 2.6.7.

I am attempting to create a WCF service. I've been unable to get either
NetTcpBinding or BasicHttpBinding working, yet both work fine if I run under

Running under Mono 2.6.7 on Windows 7 x64, I occasionally get an exception
"Exception during finishing channel acceptance" with a
System.IndexOutofRangeException: Array index is out of range. This happens
half the time that I run the service. I never get these exceptions if I am
running under .NET.

The end of the stack trace looks like:
  at (wrapper stelemref) object:stelemref (object,intptr,object)
(IChannel item) [0x0001a] in
  at System.ServiceModel.Dispatcher.ListenerLoopManager.ChannelAccepted
(IChannel ch) [0x0004c] in
(IAsyncResult result) [0x00000] in

I can provide the full stack trace if needed.

When the service does start, any clients that attempt to connect get an
Error 400.

I create the ServiceHost with:

            var host = new ServiceHost(typeof(TestService));
            host.AddServiceEndpoint(typeof(ITestService), new
BasicHttpBinding(), "");

I have also attempted to run the service under OpenSuSE 11.3, and get the
same Error 400. Everything works fine under .NET 3.5 however.

I have set all the buffer sizes to their max value.

I'd appreciate any help or direction (or if I should be sending this to
another list).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20100811/3e6d8221/attachment.html 

More information about the Mono-devel-list mailing list