[Mono-dev] ASP.NET MVC 3 Preview

Tomi bosak.tomas at gmail.com
Tue Aug 3 12:25:14 EDT 2010

Hi folks,

I wanted to try out preview version of ASP.NET MVC 3 on trunk version
of mono, so I downloaded it from git (mono, xsp, mod_mono). Then I
removed [MonoTODO] attribute on line 806 (IsFullyTrusted property) in
Assembly.cs (http://github.com/mono/mono/blob/master/mcs/class/corlib/System.Reflection/Assembly.cs)
because otherwise I would get "Method not found" error. After setting
up this "modified" parallel environment and configuring
apache/mod_mono to use mod-mono-server4 I get this stuff:


The view 'Index' or its master was not found. The following locations
were searched: ~/Views/Home/Index.aspx ~/Views/Home/Index.ascx
~/Views/Shared/Index.aspx ~/Views/Shared/Index.ascx
~/Views/Home/Index.cshtml ~/Views/Shared/Index.cshtml

Description: HTTP 500. Error processing request.

Stack Trace:

System.InvalidOperationException: The view 'Index' or its master was
not found. The following locations were searched:
  at System.Web.Mvc.ViewResult.FindView
(System.Web.Mvc.ControllerContext context) [0x00000] in <filename
  at System.Web.Mvc.ViewResultBase.ExecuteResult
(System.Web.Mvc.ControllerContext context) [0x00000] in <filename
  at System.Web.Mvc.ControllerActionInvoker.InvokeActionResult
(System.Web.Mvc.ControllerContext controllerContext,
System.Web.Mvc.ActionResult actionResult) [0x00000] in <filename
  at System.Web.Mvc.ControllerActionInvoker+<>c__DisplayClass1e.<InvokeActionResultWithFilters>b__1b
() [0x00000] in <filename unknown>:0
  at System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilter
(IResultFilter filter, System.Web.Mvc.ResultExecutingContext
preContext, System.Func`1 continuation) [0x00000] in <filename
Version information: Mono Runtime Version: 2.7 (master/93d28e4 Mon Aug
2 22:02:50 CEST 2010); ASP.NET Version: 4.0.30319.1


MVC 2 based applications work, either with mod-mono-server2 (target
framework 3.5) or mod-mono-server4 (target framework 4.0), but MVC 3
(which have to be .net 4.0) gives above error. I tested both view
engines (classic aspx and new razor) with the same result. MVC 3 dll
assembly is copied locally into bin folder and loaded normally when I
try to use reflection during runtime to check it. I also tried to
check if the requested paths are not different under windows and
linux, but they are the same. Do you have any thoughts on what may be
wrong? Thanks for your time.

More information about the Mono-devel-list mailing list