[Mono-dev] Mono SVN doesn't build on Mac OSX Snow Leopard

Tom Philpot tom.philpot at logos.com
Wed Sep 23 19:32:07 EDT 2009

We were able to get Mono SVN building on Snow Leopard with the following

CFLAGS="-m32 -Dmacosx -D_XOPEN_SOURCE"

On 9/8/09 5:22 PM, "Geoff Norton" <gnorton at novell.com> wrote:

> I have some experimental patches for amd64-darwin-mono, but not ready
> yet.  For now you should set the CFLAGS="-m32"
> -g
> On 8-Sep-09, at 8:14 PM, Tom Philpot wrote:
>> The primary reason seems to be that the default version of gcc on Snow
>> Leopard, 4.2.1,  no longer defines __i386__. gcc 4.2.1 defines
>> __x86_64__.
>> I started down the path of modifying some of the #defines to correctly
>> target DARWIN and use __x86_64__, but I ran into trouble building
>> aot-runtime.c because mini.h wanted to use the -x86 sources not the
>> amd64
>> sources.
>> Has anyone else tried to build Mono from SVN on Snow Leopard?
>> Thanks,
>> Tom
>> _______________________________________________
>> Mono-devel-list mailing list
>> Mono-devel-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list