[Mono-dev] Question about Zeroconf sample

pablosantosluac at terra.es pablosantosluac at terra.es
Sun Mar 1 17:20:46 EST 2009


I don't know if there's a more suitable place to send this, if so, 
please let me know.

I was trying today the sample on the Mono Zeroconf 
(http://www.mono-project.com/Mono.Zeroconf) page.

Well, I run it on my OpenSuse box, but the client (nor mzclient) can't 
see the registered service...

No error or exception is raised but the following code

RegisterService service = new RegisterService ();
service.Name = "Aaron's DAAP Share";
service.RegType = "_daap._tcp";
service.ReplyDomain = "local.";
service.Port = 3689;

// TxtRecords are optional
TxtRecord txt_record = new TxtRecord ();
txt_record.Add ("Password", "false");
service.TxtRecord = txt_record;

service.Register ();

doesn's seem to register the service correctly

I run it both as regular user and root, and I also checked I've the 
Zeroconf package installed (and of course the Mono assemblies)



More information about the Mono-devel-list mailing list