[Mono-dev] Windows/CygWin: Mono doesn't work after compiling

MikeTheTall michpa at hotmail.com
Wed Oct 29 15:00:48 EDT 2008


I'm having a bit of trouble compiling mono on Windows (using CygWin).  The
weird thing is that the compilation seems to have gone ok, but the
mono/mcs/gmcs programs do nothing afterwards.

To compile, I followed the directions at
http://www.mono-project.com/Compiling_Mono#Windows_Compilation.  I started
by installing the "Mono 2.0 For Windows" binaries onto my computer, got
everything that CygWin needs, then grabbed the mono-2.0.1.tar.bz2  from
http://ftp.novell.com/pub/mono/sources-stable/.  I then tried to build
everything, failed because I didn't have the right version of make (which I
then got).  With the older version of make everything seemed to compile just
fine - there were no error messages printed at the end of the build.

Now here's where it gets weird: when I add mono's bin directory to my path,
and type "mono" into my bash shell, nothing happens.  I hit enter, there's a
brief pause, then the command prompt re-appears.  There's no error messages
(and "which mono" correctly identifies the mono.exe that I"m trying to use),
but there's no output, either.  mono -V also produces no output.  When I run
through the console basics example at http://mono-project.com/Mono_Basics,
mcs and gmcs do no produce error messages, but they also don't produce a
.exe, either.  

The other odd thing is that if I use the gmcs compiler directly
(..../lib/mono/2.0/gmcs.exe hello.cs), I get an exception (Unhandled
Exception: System.ArgumentException: Illegal enum value: 2050. Parameter
name: access), but if I use ..../lib/mono/1.0/mcs.exe hello.cs, it at least
gives me a compiled .exe.  At least for Windows, it looks like the compilers
in $MONO_LOCATION/bin are just bash scripts that point to the above
executables (I'm not sure why the scripts don't work, but the compilers
themselves do)

I'm really sorry for posting this, since I'm 100% sure that it's something
I'm missing on my end, but if anyone has any suggestions, I'd love to hear
them.  I think I"m going to try a clean build again (in case the wrong make
somehow messed things up), but I'm not really hopeful that that will fix
things :}

View this message in context: http://www.nabble.com/Windows-CygWin%3A-Mono-doesn%27t-work-after-compiling-tp20233695p20233695.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list