[Mono-dev] problem building mono, can't get monolite to work

Andreas Färber andreas.faerber at web.de
Sat Oct 4 07:42:38 EDT 2008

Hi Cetin!

Am 03.10.2008 um 23:01 schrieb Cetin Sert:

> I'm also trying to build mono on opensolaris 10 x86-64 and got this  
> message:
> when I run ./configure --with-gc=boehm
> checking gc.h usability... no
> checking gc.h presence... no
> checking for gc.h... no
> checking gc/gc.h usability... no
> checking gc/gc.h presence... no
> checking for gc/gc.h... no
> checking for GC_malloc in -lgc... no
> configure: error: "GC requested but libgc not found! Install libgc  
> or run
> configure with --with-gc=none."
> I had built and installed the latest boehm gc I could find. I think  
> it was version 7.sth.

Did you add appropriate CPPFLAGS and LDFLAGS arguments for configure,  
to tell it about your installation location?

> And if I configure mono using --with--gc=none how can I add a gc  
> later? o_O??

Well, the --with-gc=none workflow would be compiling without first,  
then reconfiguring and recompiling with some other --with-gc= option  
later on.

On x86-64 OpenSolaris, you can use --with-gc=boehm right away, worked  
nicely with Boehm GC 7.1 for me. If there is a compilation problem in  
Boehm GC, you may need to install a more recent build (some in the low  
90 range was broken).

Best regards,


More information about the Mono-devel-list mailing list