[Mono-dev] Compiling Mono on CygWin/Windows: Monoburg problem?

MikeTheTall michpa at hotmail.com
Sun Nov 2 14:03:56 EST 2008


I posted a couple of days back because I'd thought that my compilation of
Mono on Windows (using CygWin, not the VS build) worked; apparently it
didn't.  I'm running into problems with the monoburg component of the build.

The symptom of the problem is that it' not producing any output.  I tried
running it by hand, within the mono-2.0.1./mono/monoburg directory, using
the line:
./monoburg ./sample.brg > sample.c

Afterwards, sample.c is 0 bytes in size.

This seems odd, but is the same symptom that I was seeing when the build
finished (mono-based programs producing literally no output).  Next, I tried
running monoburg directly under the pre-compiled version of mono that I had
already installed (which is what I thought I was doing - I had
/cygdrive/c/Programs/Mono-2.0/bin/ in my path already)

The thing that confuses me is that I've got my pre-compiled Mono's bin
directory in my path, so if there are any needed .dll's, monoburg should
find it there.

When I try to run it under gdb, it exits with error code 0xc000007b.  catch
stop, catch load, and a couple other things (catch start?) aren't
implemented, which would seem to be the way to get a closer look at what's
going on; 0xc000007b appears to be a (?)Windows error code for "application
did not initialize properly", which does suggest that a .DLL is missing,

Sorry to bug y'all with this, but if anyone has any ideas about what to look
at next, or what I might be doing wrong, I'd greatly appreciate it!

View this message in context: http://www.nabble.com/Compiling-Mono-on-CygWin-Windows%3A-Monoburg-problem--tp20292758p20292758.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list