[Mono-dev] Mono 2.0 and FreeBSD

Romain Tartière romain at blogreen.org
Mon Dec 8 09:02:16 EST 2008


[Note to Geoff Norton in CC]
    I saw a message [0] from you about Mono working on FreeBSD so I put
you in CC since you may have some relevant information to provide ;-)
[End of note]

    The BSD# project [1] aims to bring Mono 2.0 on the FreeBSD operating
system.  While Mono is already available on this platform [2], it is
quite outdated: the latests available version is

    Updating to the latest version is unfortunately not as easy as
expected: basically, mono builds without incident, but not all programs
are working correctly.  Regression tests are causing trouble, so I guess
they have to pass before we can try to see what is okay and what is not.

    In the past few weeks, I tried to track down the mono subversion
tree to get to the commit that broke NullReferenceException down: the
test mono/tests/exception.exe pass with <=mono- but either ABRT
or hangs-on with more recent version of mono.  I stopped my tests with the
version of 2006-10-31 (rev. 67196) from the trunk where the problem is
still present.  As far I as understand, the development did not took
place in trunk or patches where applied for the release since
mono-1.2.5 was tagged many month after this date.

    I am therefore still not able to understand what is happening and
I am so trying to get more info at the source.  I have put the result of
running exception.exe here [3].  The program [3.1]  hangs consuming CPU
time until it gets killed.

    I am not sure about the gdb backtrace [3.2]: I followed the
instructions about debugging [4] but I have weird results such as:
> #3  0x00000000 in ?? ()
> #4  0x00000000 in ?? ()
> #5  0x00000000 in ?? ()
> #6  0x00000001 in ?? ()
> #7  0x00000000 in ?? ()
... which I don't think is good (too much 0x00000000)...

    This is on FreeBSD 7.1-PRERELEASE i386 with mono-2.0.1 [3.3].

    Any idea for a better backtrace is welcomed.  Any hint is welcomed.
Any branch of mono to checkout and test too.  If required, I can even
provide an SSH connection to a FreeBSD box and assistance to a Mono-guru
to hack and fix this bug (Okay, I think you understood that I _really_
want this to work on FreeBSD!).

    I hope that mixing the BSD# team's knowledge of FreeBSD and your
knowledge of Mono internals will result in having a working Mono 2.0 on

With kind regards,
Romain Tartière,
on behalf of the BSD# Project.

    0. http://lists.ximian.com/pipermail/mono-devel-list/2008-November/029685.html
    1. http://code.google.com/p/bsd-sharp/
    2. http://www.freshports.org/lang/mono/
    3. http://mono.sigabrt.org/
    3.1 http://mono.sigabrt.org/exception.cs
    3.2 http://mono.sigabrt.org/gdb
    3.3 http://mono.sigabrt.org/VERSION
    4. http://www.mono-project.com/Debugging

Romain Tartière <romain at blogreen.org>        http://romain.blogreen.org/
pgp: 8DAB A124 0DA4 7024 F82A  E748 D8E9 A33F FF56 FF43 (ID: 0xFF56FF43)
(plain text =non-HTML= PGP/GPG encrypted/signed e-mail much appreciated)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20081208/e80a2e62/attachment.bin 

More information about the Mono-devel-list mailing list