[Mono-dev] mkbundle generated windows executable troubleshooting

bpack958 brianpack958 at hotmail.com
Sun Aug 17 22:53:11 EDT 2008

Hello guys, i'm really new at this and would first like to apologise if there
has been a post about this before.

I have my .Net application which works fine executing under mono (I've tried
1.9.1 and 2.0 Beta and I use the Windows environment). I have also managed
to compile a windows exe using mkbundle, I used the command "mkbundle <app
name> -o test.exe --deps".

My problem is that when I try to run my newly created exe generated from
mkbundle nothing happens. There is no error message, nothing seems to crash.
When run from the command prompt all that happens after running is that I am
returned to the command prompt. I have used filemon (sys internals) and I
can see my app is executing the inital code to access a config file but
doesn't get far before it just ends (well before it loads a splash screen).

I have tried using mkbundle with a simple Windows Forms app with a message
box and a few other things. This test app works fine no worries so, there
must be something my app is using.

My question is really about how one would really go about diagnosing
problems like these? 

Being new I'm not quite sure why the app works fine running under mono but,
when compiled with mkbundle its having issues. I'm also wondering if there
is anyway to get better debug info (for example i'm wondering if its looking
for a missing dll or something and then crashing out silently).
View this message in context: http://www.nabble.com/mkbundle-generated-windows-executable-troubleshooting-tp19025329p19025329.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list