[Mono-dev] Compiling Mono on SPARC

PCM Reddy Pcm.Reddy at Sun.COM
Fri Apr 18 14:53:20 EDT 2008

Andreas Färber wrote:
> Hi,
> Am 18.04.2008 um 02:27 schrieb PCM Reddy:
>>  I tried to compile Mono 1.2.6 on Solaris SPARC with gnutoolchain and
>> it failed to compile "mcs" target. When I look at the details for mcs
>> target. I got the following  error.
>> Any suggestion or workarounds to compile Mono 1.2.6 on SPARC.
>> When I tried to run gmake in mcs folder. I see this error, may be the
>> this is the cause of the problem.
>> gmake[2]: Entering directory `/tmp/mono-1.2.6/mcs/mcs'
>> gmake[2]: *** No rule to make target
>> `../class/Mono.CompilerServices.SymbolWriter/MonoSymbolFile.cs', needed
>> by `../class/lib/default/mcs.exe'.  Stop.
>> gmake[2]: Leaving directory `/tmp/mono-1.2.6/mcs/mcs'
>> gmake[1]: *** [do-all] Error 2
>> BTW, I also tried to copy this files from mono1.9 and still does not 
>> work.
> Did you use Solaris' tar? You need to use gtar instead.
> Also, iirc on Solaris there is another "mcs" program that interferes 
> with Mono's bootstrapping. You may need to adjust your $PATH.
Yes, I am using gtar. also renamed the original solaris  "mcs" command too.
Now I downloaded latest mono-1.9 and tried to compile.

Compilation failed at "mcs" and  When I ran gmake from mcs folder this 
is what I got.

mkdir -p -- ../class/lib/default/
touch ../class/lib/default//.stamp
../class/lib/net_1_1_bootstrap/mcs.exe /codepage:65001   -d:NET_1_1 
-d:ONLY_1_1 -debug -target:exe -out:mcs.exe cs-parser.cs  @mcs.exe.sources
Segmentation Fault - core dumped
gmake[2]: *** [../class/lib/default/mcs.exe] Error 139
gmake[2]: Leaving directory `/tmp/mono-1.9/mcs/mcs'
gmake[1]: *** [do-all] Error 2


> Andreas

More information about the Mono-devel-list mailing list