[Mono-dev] Gecko - linux - error compilation

agostinhomt agostinhomt at netcabo.pt
Sat Jun 16 21:04:14 EDT 2007

I want to use "Gecko" for viewing a web browser in my project in Ubuntu.
I create a new project "gtk#2", I begin to wrote my code and I insert the line "using Gecko;"  and it does not apear automatically on the list of possible code. I presume it is not installed for programming.
After that I tried to install a new mono, compiled with svn or source tar.gz, but this 2 solutions gave me some errors.
My last eforts is to install mono with monodevelop 0.14 like here: http://www.monodevelop.com/Download. 
I wrote in my terminal "./configure --prefix=/usr/local" and it Worked fine,
I write "make" and it gaves me 1 error.
"make[3]: ** [../../../build/AddIns/MonoDevelop.Dock.dll] Error 1"

Sorry my English
Configuration summary
 * Installation prefix = /usr/local
   * C# compiler = /home/ag/mono-1.2.4/bin/gmcs
   * Mozilla home: /usr/lib/firefox
   * mono-debugger: no
   * MonoQuery support: yes
   *   Providers:
   *     PostgreSQL:   yes
   *     MySQL:        yes
   *     SQLite:       yes
   *     Oracle:       yes
   *     SQL Server:   yes
   *     Sybase:       yes
   * java support: no
   * boo support: no
   * Nemerle support: no
   * Mono class library development extensions: yes
   * Version control support: yes
   *   Providers:
   *     Subversion: no
   * ASP.NET project support: no
   * ASP.NET Visual Designer: no
   * Web References: yes

In my terminal I wrote "make" and it gaves me this error.
make[2]: Entrando no diretório `/home/ag/mono-pk/monodevelop-0.14/Core/src'
Making all in MonoDevelop.Dock
make[3]: Entrando no diretório `/home/ag/mono-pk/monodevelop-0.14/Core/src/MonoDevelop.Dock'
mkdir -p ../../../build/bin/
/home/ag/mono-1.2.4/bin/gmcs -debug -codepage:utf8 -out:../../../build/AddIns/MonoDevelop.Dock.dll -target:library ./AfterAttribute.cs ./AssemblyInfo.cs ./DetachedHandler.cs ./Dock.cs ./DockBar.cs ./DockBarButton.cs ./DockedHandler.cs ./DockItem.cs ./DockItemBehavior.cs ./DockItemGrip.cs ./DockLayout.cs ./DockMaster.cs ./DockNotebook.cs ./DockObject.cs ./DockObjectFlags.cs ./DockPaned.cs ./DockPlaceholder.cs ./DockPlacement.cs ./DockRequest.cs ./DragNotebook.cs ./ExportAttribute.cs ./Stock.cs  /resource:./layout.glade /resource:./stock-close-12.png /resource:./stock-menu-left-12.png /resource:./stock-menu-right-12.png /usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig: /usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig: /usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig: -r:Mono.Posix -r:System -r:System.Xml
warning CS2002: Source file `/usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig:' specified multiple times
warning CS2002: Source file `/usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig:' specified multiple times
error CS2001: Source file `/usr/local/lib/pkgconfig:/home/ag/mono-1.2.4/lib/pkgconfig:' could not be found
Compilation failed: 1 error(s), 2 warnings
make[3]: ** [../../../build/AddIns/MonoDevelop.Dock.dll] Erro 1
make[3]: Saindo do diretório `/home/ag/mono-pk/monodevelop-0.14/Core/src/MonoDevelop.Dock'
make[2]: ** [all-recursive] Erro 1
make[2]: Saindo do diretório `/home/ag/mono-pk/monodevelop-0.14/Core/src'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretório `/home/ag/mono-pk/monodevelop-0.14/Core'
make: ** [all-recursive] Erro 1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20070617/aff6b7ab/attachment.html 

More information about the Mono-devel-list mailing list