[Mono-dev] Compilation problems

=?UTF-8?Q?Szentp=E1li_J=E1nos?= ianus at easynet.ro
Fri Jul 20 20:18:05 EDT 2007

I am trying to install Monodevlop but I can't: when I give the 
./configure command it says at some point:

--- START ---

checking for GNOME_SHARP... configure: error: Package requirements 
(gnome-sharp-2.0 >= 2.8.0) were not met:

No Package 'gnome-sharp-2.0' found

--- STOP ---

But I did compile and install gnome-sharp 2.16.0 and it only warned 3 
times but compiled and installed.
When I ran ./configure for it, at the end it said:

--- START ---

Optional assemblies included in the build:

    * gnome-sharp.dll: no

    Note: if any of the above say 'no' you may install the
          corresponding development packages for them, rerun
          autogen.sh to include them in the build.

--- STOP ---

This makes me think: is it possible that that no is the source of all my 
problems? If yes how do I make it to build gnome-sharp.dll. I mean what 
could it be the corresponding development package? And how do I run that 
autogen.sh especially since it is located in a single folder somewhere 
in some java folder that has nothing to do with mono or monodevelop? 
Mono runs OK. I made some tests, they both compiled and ran just fine.
I am using a Slackware based Zenwalk GNU/Linux OS.
Is there a cure for my problems?

Oh, and I hope this is the right mailing list :O

More information about the Mono-devel-list mailing list