[Mono-dev] ASP.NET ObjectDataSource problem

Dariusz Linowski darlin1 at linbit.pl
Wed Jan 3 07:59:35 EST 2007

I have some problem with ASP.NET application under mono
(mod-mono-serwer2)  with sys.web library when my  ObjectDataSource
type call my business class I received error:
: Type not found: ShipperDataLayer.

My piece of default.aspx code:

<asp:ObjectDataSource ID="ObjectDataSource1" runat="server"

My piece of Business class : ShipperDataLayer:

public class ShipperDataLayer
        public static DataTable GetShippers()
    return DataLayerHelper.Get("SELECT * FROM shipper");

This application work correct under windows 2.0 framework.
I tried run this application on two ways: to put this class as .cs
file in the App_Code directory and tried to put as .dll library in the
bin directory.
but error is the same.
I found similar problem in Bugzilla 78321 bag, but in the latest mono
it doesn't work stil, or it could be caused by my mistake. I'm mew in
mono and asp.net. So, every suggestion will be acceptable.

Dariusz Linowski

More information about the Mono-devel-list mailing list