[Mono-dev] Problems Compiling Mono in Cygwin

Rolf Bjarne Kvinge rolflists at ya.com
Fri Dec 14 05:06:37 EST 2007



#2 has happened to me a couple of times too when running 'make'. It's a very
sporadic error which occurs once in a while and in different places, so what
I did was running make again until it finished successfully (it always got a
little bit further while compiling, until it finished successfully).




From: mono-devel-list-bounces at lists.ximian.com
[mailto:mono-devel-list-bounces at lists.ximian.com] On Behalf Of Luke Page
Sent: viernes, 14 de diciembre de 2007 10:54
To: mono-devel-list at lists.ximian.com
Subject: [Mono-dev] Problems Compiling Mono in Cygwin



I am currently pulling my hair out over compiling the latest trunk of mono
from SVN. I have XP SP2 and am following Shana's guide as suggested by the
mono website ( http://shana.iidbbs.com/en/mono_cygwin_tutorial.html
<http://shana.iidbbs.com/en/mono_cygwin_tutorial.html> ).

The first problem may be irrelevant, as I solved it, but it does seem

Problem 1:
The compiler failed to build System.XML, with the the following messages 


It appeared that even though the makefile specified it and the echo command
was on the shell output, no define was put in PatternParser.cs in
System.XML/Mono.Xml.Xsl which meant it was identical to

I added the define at the top of the generated PatternParser.cs file and the
build continued.

Using the new 1.2.6 source tar ball the build then finished and appears to
work. With the SVN build I got the second problem. I then uninstalled Cygwin
and installed it again, re-got the SVN and tried compiling again. I fixed
problem 1 again and still got problem 2. I then tried a "make distclean" in
case the previous failure caused some problems. I tried re-getting the SVN
again and fixing problem 1 before attempting a build, all without success. 

Problem 2:

I get a microsoft unhandled exception message, with no output error
(http://pastebin.com/m58cea243). When I try running the command from the log
in the same directory I get the following error and no unhandled exception

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the

The directory part "lib\mono\2.0" doesn't exist. When I try using 1.2.6
dll's in this location it complains of a version mis-match, wanting version
63 instead of 60.

I've tried everything I can think of and would now really appreciate any
help or suggestions as to what to try next. 

Is it possible the SVN is now broken when building in windows and I need to
go back to 1.2.6 and then only update the section of code I want to update?
I'm obviously not relishing this choice.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20071214/0ab845b1/attachment.html 

More information about the Mono-devel-list mailing list