[Mono-dev] Trouble installing

Chris Dunning chris at bluenoteweb.com
Sat Apr 7 19:22:02 EDT 2007

I'm having an issue installing Mono on my server, hopefully someone out
there can point me in the right direction.

The server runs CentOS 4, kernel 2.6.9-42.0.3.ELsmp.  I'm running Apache
1.3.37.  I installed mono, xps and mod_mono using yum and the repository
available here:

The commands I executed were pretty straightforward:
yum install mono*
yum install xps*
yum install mod_mono

Everything appeared to install with no problem.  Yum dropped a conf file
into /etc/httpd/conf.d which was automatically included when I restarted
Apache.  The restart failed with this error:

Syntax error on line 8 of /etc/httpd/conf.d/mod_mono.conf:
Cannot load /usr/lib/httpd/modules/mod_mono.so into server:
/usr/lib/httpd/modules/mod_mono.so: undefined symbol: apr_pool_cleanup_null

A quick google turned up this page:

Following that path, I upgraded apr and related packages to the latest
RPMs available on the Apache mirrors.  Still no go, same error.

What's the next step to check?  Thanks in advance to any who can help.

More information about the Mono-devel-list mailing list