[Mono-dev] Oracle Client Installation problem (solution)

APS subscription.sapi at apsystems.it
Wed Jun 21 07:39:59 EDT 2006

I solved it by myself. I post the solution in order to help other 
people with the same problem.
I think that the problem is that mod_mono (rh 1.1.14) (doesn't use 
the path you place in /etc/mono/config file but always search the 
file inside default directories (in fact specifying the full path was 
not a solution for me, a bug?).
This implies that you have to correctly setup the LD_LIBRARY_PATH 
according to your Oracle Instant Client installation.
If you do that in profile configuration and you manually launch xsp 
(1.1.15)(or mod-mono-server I think) always goes well.
The problem is that apache (httpd for RH) doesn't use that 
configuration, you have to manually add it to apache initialization 
files (I placed it into /etc/init.d/httpd) a command like

export LD_LIBRARY_PATH=<oracle client path>:$LD_LIBRARY_PATH
export TNS_ADMIN=<oracle client path>

In this way when apache load the user configuration adds your oracle 
Instant Client installation to the path and mod_mono finds the libraries.

Maybe someone with more experience in linux, apache and mod_mono can 
explain better why this happens, and why specifying full path in mono 
config doesn't work but using this method you can solve your oci missing error.
Hope this helps.

>I'm trying to setup my mono installation in order to use Oracle 10g.
>- I unpacked Oracle Instant Client into /lib/oracleclient directory 
>giving read access to everyone
>- I configured in profile LD_LIBRARY_PATH,ORACLE_HOME and path 
>(using pathmunge) with the /lib/oracleclient directory
>- I  configured /etc/mono/config file according to the 
>configuration, I tried with /lib/oracleclient/libclntsh.so.10.1 and 
>libclntsh.so.10.1, with /lib/oracleclient/libclntsh.so and 
>/lib/oracleclient/libclntsh.so making a link to 
>- I tested my installation using sqlplus and it works fine.
>Launching my application I always obtain
>System.DllNotFoundException: libclntsh.so.10.1
>System.DllNotFoundException: libclntsh.so
>System.DllNotFoundException: /lib/oracleclient/libclntsh.so.10.1
>System.DllNotFoundException: /lib/oracleclient/libclntsh.so
>What other things can I check? I searched the web but I've found 
>nothing more than I've already done.
>I'm using RedHat AS v4.0. Thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20060621/c5256cde/attachment.html 

More information about the Mono-devel-list mailing list