[Mono-dev] mono-service again (BUG FIX)

pablosantosluac at terra.es pablosantosluac at terra.es
Wed Jun 7 06:06:41 EDT 2006


First of all I don't understand why I'm supposed to be doing 
thread-hijacking. Is not this the place to post questions about 

Anyway, it seems there is a bug in mono-service. Whenever it tries to launch 
a service application it raises an exception in mono-service.cs at method 

The code is doing something like:

string [] service_args = new string [0];

entry.Invoke(null, service_args);

return 0;

And it raises the exception I posted in a previous email.

Doing the following:

string [] service_args = new string [0];

object[] obj = new object[1];

obj[0] = service_args;

entry.Invoke(null, obj);

return 0;

The problem seems to be solved.

I replaced the mono-service.exe on my Fedora4/mono-1.1.15 and now it works.



----- Original Message ----- 
From: "Ympostor" <ympostor at clix.pt>
To: <mono-devel-list at lists.ximian.com>
Sent: Wednesday, June 07, 2006 10:09 AM
Subject: [Mono-dev] [OT] Thread hijacking (was: Re: mono-service again)

> pablosantosluac at terra.es escribió:
>> Hi all,
>> ...
> Hello. Sorry for the Off-Topic but this is the second message from you in 
> which I see you are making Thread Hijacking [1].
> For the cleanliness of the list, please stop doing it.
> Regards.
> -- 
> [1] http://en.wikipedia.org/wiki/Thread_hijacking
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list 

More information about the Mono-devel-list mailing list