[Mono-dev] AJAX problem with Mono

Webmaster webmaster at triposcope.com
Fri Jan 13 12:00:55 EST 2006

Hello all,


I am having some problems installing AJAX in conjunction with Mono.
Everything seems to have went well up until I tried to call a serverside
javascript function. I got an error saying object undefined. I then tried to
navigate the SRC of the apparently created javascript include, and there was
nothing. I got an error saying file not found. 


I think I configured my http handlers correctly, at first I was placing the
app in the subdirectory of another Mono app, and so changed it to its own
space on my server. Still generated problems. Ajax is either creating the
files and placing them where I can't see them, or its not creating them at


I followed the instructions that came with AJAX implicitly and I am still
having problems. Can AJAX even be installed on MONO? Does anyone have any
success stories?


I know I am calling the registerAjax function properly, because I get the
output in my source. I just cant see where the outputted JS files are being

Another thing too, is AJAX supposed to place the JS include code right
before a FORM object or in the head? It outputs the JS include right after a
form element, could this be a problem? 


Any help would be greatly appreciated.


Best Regards


Martin Tuncaydin

webmaster at triposcope.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20060113/79672b1b/attachment.html 

More information about the Mono-devel-list mailing list