[Mono-dev] ASP.NET bin folder and referenced assemblies

Piotr Stulinski jamjar at gmail.com
Fri Dec 1 02:57:41 EST 2006

Greetings fellow monkeys

I have been stumped with a particular irritating problem for the past
few weeks now.
I have the simplest mono ASP.NET website - it compiles 100% fine and
runs fine on windows... so no program error... i am running mono on my
Ubuntu machine and it just wont work! The program is so simple its
driving me insane..

The Program:

1) a DLL file which i compiled seperately Blah.dll with a simple
public function HelloWorld() which simply returns "hello world" - this
is in the bin folder

2) a plain webpage with code on it that simple initialises the class
in the above DLL and puts the output onto a label.

The Problem:

When i try run it on my ubuntu box it tells me it cant find the
referenced assembly.

How did i get it onto my linux box:
1) Simply copied it over into my xsp2 web server root via FTP.

What have i tried to date:
1) making sure the dll is executable (+x on unix machines)
2) i thought it might be a capitalistion problem so i copied my Bin - to - bin
3) i even tried to add the assembly into the web.config it wont find
it anywhere.
4) i did a chmod 777 for the entire webroot - just to test if it was a
permission problem.
5) having failed with all of the above, i tried to  start fresh and
copy the .cs file into the App_Code folder and see if mono would
autocompile it for me as i understand 1.2.1 has autocompile
functionality as per vs 2005 - i get exactly the same problem mono
tells me it cant find the dll - the reference library does not exist

I am sure my mono is working as if i write simple ASP.NET code onto
the actual aspx page it works 100%.

I am really new to mono, so maybe i am doing something wrong... i have
a good couple years c# experience any fellow monkey who can shed light
on this - i'll give you a banana.


More information about the Mono-devel-list mailing list