[Mono-dev] Cross compiling mono for arm-linux targated at 2.6 kernel

Vinayak Naik naik at cens.ucla.edu
Tue Aug 29 18:40:27 EDT 2006


I am trying to compile mono- for a arm-linux device running
2.6 kernel. I tried to use mono for nokia 770 but it failed. I guess
the reason is because nokia 770 uses 2.4 kernel.

I tried to use scratchbox but it failed since my device is new and its
toolchain is not yet provided for scratchbox. Hence I am trying the
old way of cross-compilation.

I configured using "/configure --target=arm-linux --host=i686-linux
--prefix=/usr/arm-linux" command. Then, I ran make which resulted in
the compilation error at the bottom of the email.

Any idea what is the reason behind the error?


- Vinayak

arm-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I../../libgc/include -DMONO_BINDIR=\"/usr/arm-linux/bin\" -I../..
-g -O2 -fno-strict-aliasing -Wdeclaration-after-statement -g -Wall
-Wunused -Wmissing-prototypes -Wmissing-declarations
-Wstrict-prototypes -Wmissing-prototypes -Wnested-externs
-Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -MT
collection.lo -MD -MP -MF .deps/collection.Tpo -c collection.c  -fPIC
-DPIC -o .libs/collection.o
In file included from ../../mono/io-layer/shared.h:13,
                 from ../../mono/io-layer/collection.h:20,
                 from collection.c:18:
../../mono/io-layer/wapi-private.h:21:2: #error configure failed to
discover size of unix socket path
make[3]: *** [collection.lo] Error 1
make[3]: Leaving directory `/home/naik/download/mono-'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/naik/download/mono-'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/naik/download/mono-'
make: *** [all] Error 2

More information about the Mono-devel-list mailing list