[Mono-dev] Building Mono on Linux/Alpha

Zoltan Varga vargaz at gmail.com
Fri Aug 25 12:35:35 EDT 2006


  You should:
- make run 'make rcheck' in mini runs without a failure.
- you can also try running 'Hello, World' at this point.
- then 'make testjit' runs in tests without a failure.

Until these do not work, there is little point in trying to run mcs.
After that you
can try 'mcs hello.cs'.


On 8/22/06, Servey Tikhonov <tsv at solvo.ru> wrote:
> Hello Zoltan,
> I am curious what to do next. :) Right now mono on Linux/Alpha passes
> almost all basic tests (I haven't tried arrays.cs yet).
> I tried to bootstrap the compiler and of cause it failed with following:
> ALPHA_TODO: [mono_arch_get_vcall_slot_addr] code: 0x20003fd288c regs:
> 0x11fc14ec8
> ** (../class/lib/net_1_1_bootstrap/mcs.exe:2346): DEBUG: ALPHA_DEBUG:
> mono_arch_patch_callsite is called.
> Patch callsite at 0x20003fd2988 to 0x20003fd2de8
> ** (../class/lib/net_1_1_bootstrap/mcs.exe:2346): DEBUG: ALPHA_DEBUG:
> mono_arch_get_vcall_slot_addr is called.
> ALPHA_TODO: [mono_arch_get_vcall_slot_addr] code: 0x20003fd28a8 regs:
> 0x11fc14ec8
> Unhandled Exception: System.TypeInitializationException: An exception
> was thrown by the type initializer for Mono.CSharp.Location --->
> System.NullReferenceException: Object reference not set to an instance
> of an object
>   at Mono.CSharp.Location.AddCheckpoint (Int32 file, Int32 row) [0x202ca308]
>   at Mono.CSharp.Location..ctor (Int32 row, Int32 column) [0x202ca308]
>   at Mono.CSharp.Location..ctor (Int32 row) [0x202ca308]
>   at Mono.CSharp.Location..cctor () [0x202ca308] --- End of inner
> exception stack trace ---
> ** (../class/lib/net_1_1_bootstrap/mcs.exe:2346): DEBUG: ALPHA_DEBUG:
> mono_arch_find_jit_info is called.
> ** (../class/lib/net_1_1_bootstrap/mcs.exe:2346): DEBUG: ALPHA_DEBUG:
> mono_arch_free_jit_tls_data is called.
> make[1]: *** [../class/lib/default/mcs.exe] Error 1
> make[1]: Leaving directory `/root/work/mono/mcs/mcs'
> make: *** [do-all] Error 2
> Well, I didn't expect it to start working right away. :) I guess I
> should be start looking at mcs/tests directory and try to run it
> one by one and see how it goes.
> How did you bootstrap a compiler? I guess it was some smaller/simpler
> version. I am using one from mono 1.1.13 version.
> Thank you,
> Sergey.
> tsv_at_solvo.ru
> Solvo Ltd.

More information about the Mono-devel-list mailing list