[Mono-dev] Unable to create unix domain socket with mod-mono under apache2 fc4

Phillip Fry zoiddy001 at yahoo.com
Fri Sep 30 03:48:42 EDT 2005


I am running into a strange problem with mod mono
server with apache 2.0.54 on fedora core 4. 

I got all the pre built yum depots for mono.  Compiled
and installed mod_mono.  Tried the example, but I
always get 503 error.  I tried deleting /tmp/.wapi
dirs that still didn't help.  I turned on debuging in
mod-mono and added more output to mod-mono-server.exe
and this is what I got. 

[Fri Sep 30 15:30:23 2005] [warn] child started
[Fri Sep 30 15:30:23 2005] [warn] PATH:
[Fri Sep 30 15:30:23 2005] [warn] monodir: /usr/bin
[Fri Sep 30 15:30:23 2005] [warn] serverdir:
[Fri Sep 30 15:30:23 2005] [warn] PATH after:
Listening on: /tmp/mod_mono_server
Root directory: /tmp
Error: System.Net.Sockets.SocketException: Access
in [0x0005a] System.Net.Sockets.Socket:Bind
(System.Net.EndPoint local_end)
in <0x00149>
Mono.WebServer.ModMonoWebSource:CreateSocket ()
in <0x0004b> Mono.WebServer.ApplicationServer:Start
(Boolean bgThread)
in (wrapper remoting-invoke-with-check)
Mono.WebServer.ApplicationServer:Start (bool)
in <0x00b6e> Mono.XSP.Server:Main (System.String[]

I am puzzled why we can't create a unix domain socket
in /tmp.  I put in some code in mod-mono-server.exe to
create regular file on start up in /tmp and that works
fine.   /tmp is rwx by everyone but I never saw any
socket file in there created by mod_mono on apache. 

Is there some env variable that apache is not setting
that mono needs to create a socket in /tmp.  Seems odd
enough that creating a regular file is OK but a unix
domain socket is denied.  Xsp and mod-mono-server all
works fine on the command line.  

It would be greatly appreciated if anyone can shed
some light on this strange behavior. 


Yahoo! Mail - PC Magazine Editors' Choice 2005 

More information about the Mono-devel-list mailing list