[Mono-dev] Solaris and 1.1.9 again... help needed

pablosantosluac at terra.es pablosantosluac at terra.es
Sun Oct 2 11:54:56 EDT 2005

Hi again,

Copied the monocharge files to /usr/local/lib/mono/1.0 and it went a bit 

It doesn't complain about the version anymore... now it simply crashes...

I run it with gdb and got the following output. I don't know whether it 
could be
related to the problem I always have trying to compile the libraries from 

bash-2.05b$ gdb ./mono
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain 
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-pc-solaris2.10"...
(gdb) run mcs.exe
Starting program: /home/pablo/monoinstall/monocharge-20050930/1.0/mono 
warning: Lowest section in /usr/lib/libthread.so.1 is .dynamic at 00000074
warning: Lowest section in /usr/lib/libpthread.so.1 is .dynamic at 00000074
[New LWP 1]
[New LWP 2]

Program received signal SIGSEGV, Segmentation fault.
0x08102e1a in GC_SysVGetDataStart (max_page_size=4096,
etext_addr=0x81a9340) at os_dep.c:1373
1373            *result = *result;
(gdb) bt
#0  0x08102e1a in GC_SysVGetDataStart (max_page_size=4096,
etext_addr=0x81a9340) at os_dep.c:1373
#1  0x08102e6b in GC_register_data_segments () at os_dep.c:1443
#2  0x08102064 in GC_init_inner () at misc.c:727
#3  0x08101cd1 in GC_init () at misc.c:492
#4  0x081223ac in mini_init (filename=0x80474f5 "mcs.exe") at mini.c:10159
#5  0x080718a1 in mono_main (argc=2, argv=0x804737c) at driver.c:846
#6  0x08070b6b in main (argc=2, argv=0x804737c) at main.c:6

----- Original Message ----- 
From: "Zoltan Varga" <vargaz at gmail.com>
To: <pablosantosluac at terra.es>
Cc: <mono-devel-list at lists.ximian.com>
Sent: Sunday, October 02, 2005 2:44 PM
Subject: Re: [Mono-dev] Solaris and 1.1.9 again... help needed


   Try copying the contents of the monocharge to the directory where
mono should be
installed, ie. mscorlib.dll should end up in <prefix>/lib/mono/1.0, ie


On 10/2/05, pablosantosluac at terra.es <pablosantosluac at terra.es> wrote:
> Hi again,
> I'm still trying to get 1.1.9 running on Solaris.
> I've uninstalled 1.0.6, the last one I was able to compile and install 
> from
> sources.
> Well, now I've tried the following:
> - downloaded the latest sources (Sept 30)
> - downloaded latest monocharge
> - compiled mono (mono/mini/mono) from source, it seems to work
> - then I tried to run mcs.exe from monocharge using the compiled mono. But 
> I
> get a version mismatch error...
> Using monodis I can check that mscorlib.dll is version 41 (0x29), and
> checking appdomain.c I get the same number for mono... (and the error
> message also tells me that).
> What I am doing wrong? :-(
> Here comes the output:
> $ uname -a
> SunOS solaris10 5.10 s10_72 i86pc i386 i86pc
> $ pwd
> /home/pablo/monoinstall/monocharge-20050930/1.0
> $ ../../mono- ./mscorlib.dll | grep
> corlib_version
>     .field private static  literal   int32 mono_corlib_version =
> int32(0x00000029)
> $ ../../mono- mcs.exe --version
> Corlib not in sync with this runtime: expected corlib version 41, found 
> 40.
> Download a newer corlib or a newer runtime at 
> http://www.go-mono.com/daily.
> $ ../../mono- --version
> Mono JIT compiler version, (C) 2002-2005 Novell, Inc
> and Contributors. www.mono-project.com
>         TLS:           normal
>         GC:            Included Boehm (with typed GC)
>         SIGSEGV      : normal
>         Globalization: normal
> $
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list