[Mono-dev] Solaris and 1.1.9 again... help needed

pablosantosluac at terra.es pablosantosluac at terra.es
Sun Oct 2 08:08:39 EDT 2005

Hi again,

I'm still trying to get 1.1.9 running on Solaris.

I've uninstalled 1.0.6, the last one I was able to compile and install from 

Well, now I've tried the following:

- downloaded the latest sources (Sept 30)
- downloaded latest monocharge
- compiled mono (mono/mini/mono) from source, it seems to work
- then I tried to run mcs.exe from monocharge using the compiled mono. But I 
get a version mismatch error...

Using monodis I can check that mscorlib.dll is version 41 (0x29), and 
checking appdomain.c I get the same number for mono... (and the error 
message also tells me that).

What I am doing wrong? :-(

Here comes the output:

$ uname -a
SunOS solaris10 5.10 s10_72 i86pc i386 i86pc

$ pwd

$ ../../mono- ./mscorlib.dll | grep 
    .field private static  literal   int32 mono_corlib_version = 

$ ../../mono- mcs.exe --version
Corlib not in sync with this runtime: expected corlib version 41, found 40.
Download a newer corlib or a newer runtime at http://www.go-mono.com/daily.

$ ../../mono- --version
Mono JIT compiler version, (C) 2002-2005 Novell, Inc
and Contributors. www.mono-project.com
        TLS:           normal
        GC:            Included Boehm (with typed GC)
        SIGSEGV      : normal
        Globalization: normal

More information about the Mono-devel-list mailing list