[Mono-dev] Problem with System.Data on linux mono

Patrick Tan pxt at optiver.com.au
Wed Nov 30 21:22:31 EST 2005

Thanks for the advice the problem I had was the sys admin only did the 
bare minimum mono install so it didn't have System.Data installed. It's 
installed and it all works now.


Atsushi Eno wrote:

> Hi,
> Patrick Tan wrote:
>> I'm just starting to work with mono on linux using C#. I have mono 
>> installed on my linux machine but when I run my C# program it gives 
>> me the following error:
>> Test.cs(2) error CS0234: The type or namespace name `Data' could not 
>> be found in namespace `System'
>> Test.cs(2) error CS0246: The namespace `System.Data' can not be found 
>> (missing assembly reference?)
>>    Try using -r:System.Data
> As this message suggests, use -r:System.Data in your command line.
> MCS has different design principle as csc has. It avoids extra
> assembly references and thus saves extraneous memory usage.
> (If you don't really have System.Data.dll and you specified
> -r:System.Data correctly, then the error message would be different.)
> Atsushi Eno

More information about the Mono-devel-list mailing list