[Mono-dev] Managed.Windows.Forms locks X11 up

Thomas Harning Jr. harningt at gmail.com
Mon Nov 21 17:14:58 EST 2005

When I run the mailclient.exe demo... it seems to operate fine
(excepting the failed mail attempts.. though that could just be due
to GMail requiring a certain form of login.)

The notepad.exe demo, however, causes X11 to hard lock,  keys become
entirely unresponsive [even terminal-changing combinations stop
working].  I can login from another computer to fix up the system,
killing X11.
I ran the test from within X and the last message visible was the
one stating the session/desktop manager.  The window space had shown
up, but just showed nothing (what was underneath the window at the
When outside of X, no session/desktop manager showed up at the
screen, and it hadn't locked up yet.  When I switched back to X, the
only change was that the menu options were rendered (File, Edit..etc).

Something evil must be going on, because normal apps should not be
able to lock X up in such a way.  Firefox 'sometimes' hard locks
X... but I 'think' it is something different... especially due to
the rarity of the Firefox+X11 locks.

Any ideas?
Thomas Harning Jr.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 265 bytes
Desc: OpenPGP digital signature
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20051121/a35efdc8/attachment.bin 

More information about the Mono-devel-list mailing list