[Mono-dev] AppDomain major problem

José Alexandre Antunes Faria spigaz at gmail.com
Sat Nov 19 01:29:20 EST 2005

Hi there guys,

Some of you were bothered by me on the IRC regarding a bug on AppDomain.

I was trying to create a clean AppDomain, but mono for some reason
copies the assemblies in the current domain.

So I was getting my own executable assembly in my new AppDomain. After
ours of reading mostly all MS documentation that I could find regarding
AppDomains. I started to suspect that it was in fact a bug.

So I downloaded .Net 2.0 and it worked just fine...

This bug just costed me 5 hours, damm, I'm stupid... I should have

Because I have spent those 5 hours trying all possible ways to get
around it, and the only way I can think of is by overriding the assembly
resolving mechanism.

Does any of you have some kind of clue of how I can get around it? Only
till someone finds time to fix it. I tried to spot the bug, but I was
brave enough to go deeper into the vm.

Yes, before you shoot me:

I just hope, this isn't another scary bug, like the one I found for
Baulig. (Baulig []s and good luck)


SpigaZ out...

More information about the Mono-devel-list mailing list