[Mono-devel-list] Re: [Nlog-list] MethodCall target not working on Windows?

Jaroslaw Kowalski jaak at jkowalski.net
Sat Jul 30 03:51:19 EDT 2005

For the readers on mono-devel: the thread started here:


I've set up mono on linux and attempted to reproduce your problem, but I get 
no error. Here's what I did:

1. Downloaded mono from Subversion
2. Compiled and installed mono from source
3. Downloaded and compiled NLog from subversion 
4. Downloaded NAnt 0.85 rc3 from nant.sf.net
5. Compiled NLog using NAnt
6. Compiled your example, ran it, working fine. It produced:

In Test.Main()
got message: Foo.Test.Main: testing log output

7. Moved the EXEs to Windows box. Ran the exe's and it worked fine producing 
exactly the same result.

Perhaps your X-Develop has some problems compiling NLog?
Jaroslaw Kowalski

----- Original Message ----- 
From: Valient Gough
To: Jaroslaw Kowalski
Cc: nlog-list at lists.sourceforge.net
Sent: Friday, July 29, 2005 1:42 PM
Subject: Re: [Nlog-list] MethodCall target not working on Windows?

On 7/23/05, Jaroslaw Kowalski <jaak at jkowalski.net> wrote:
Would you care to report the mono bug report on this?
Are you using NAnt to compile on linux ?

I'm going to forward to the mono list to see if anyone knows what's going 
on.  I did a diff of the IL code generated from the Windows build vs the 
Mono build, and they have some interesting differences, but I don't know 
enough about IL to know if they are both correct.

I didn't use Nant for the build, I built from the  .snl / .csproj files 
using X-develop ( http://www.omnicore.com/xdevelop.htm)


More information about the Mono-devel-list mailing list