[Mono-devel-list] Strange permissions problem

James Fitzsimons james.fitzsimons at gmail.com
Sat Jan 15 17:51:46 EST 2005

Hi all,

This is a bit embarrassing, but I can't figure out whats wrong. I have
mono-1.1.3 installed and I have somehow broken my install such that I
can now only run mcs/gmcs and mono applications as root.

If I run mcs from the prompt as a normal user it simply hangs e.g.
james at athos src $ mcs


where as if I run as root or with root permissions (i.e sudo) :
james at athos src $ sudo mcs
error CS2008: No files to compile were specified
Compilation failed: 1 error(s), 0 warnings
james at athos src $ 

I have checked the permissions on the executables but they look ok. eg.
james at athos src $ ls -la /usr/local/bin/mcs
-rwxr-xr-x  1 root root 72 Jan 14 21:48 /usr/local/bin/mcs
james at athos src $ ls -la /usr/local/lib/mono/1.0/mcs.exe
-rwxr-xr-x  1 root root 751616 Jan 14 21:47
james at athos src $

I have tried reinstalling mono but not luck :-(

Anybody have any ideas?

James Fitzsimons
It's 5.50 a.m.... Do you know where your stack pointer is ?

More information about the Mono-devel-list mailing list