[Mono-devel-list] Can't build monodoc from svn - Success

Joe Audette joe_audette at yahoo.com
Tue Feb 8 08:53:20 EST 2005

Ben's suggestion to get gtk-sharp-1-0-branch worked just fine for me. After that I was able to build monodoc and MonoDevelop with no problems.
I am one happy camper! Thanks to Ben and Paul and Mike for helping me through the tough spots in getting setup to build from svn! Its all working like a charm now, mono, xsp, mod_mono, monodoc and MonoDevelop!
Go mono!

Jacques Beaurain <jacques.beaurain at gmail.com> wrote:
I had this same problem a while back when I wanted to play around with
mono, and I did not want to mess about with a mixed system. I use
Ubuntu Hoary, if I installed the 1.0 gtk-sharp using apt-get then I
get all its dependencies in /usr. Now when I get the latest sources
from SVN, compile and install them, they end up in /usr/local. You
can't change it with --prefix, because of some complaint from profiler

Although I tried the mixed solution for a while, it did not work very
well. Here is my suggestion for working from SVN:

1. Clean of all mono related packages from your system.
2. Get mono from SVN. 
3../autogen.sh;make get-monolite-latest;make bootstrap;make install
4. Download the 1.0. gtk-sharp from
5. Untar, ./configure and make install it.
6. Now go ahead and build monodoc etc.

BTW I once did the symlink thing as well, that is just looking for trouble.



On Tue, 8 Feb 2005 07:44:39 -0500 (EST), Ben Maurer wrote:
> > Hi,
> >
> >> I'm getting this error when I run
> >> ./autogen.sh --prefix=/usr
> >>
> >> checking for gtk-sharp >= 0.91 gtkhtml-sharp >= 0.91
> >> glade-sharp >= 0.91 mono >= 0.90... Package gtk-sharp
> >> was not found in the pkg-config search path.
> >> Perhaps you should add the directory containing
> >> `gtk-sharp.pc'
> >> to the PKG_CONFIG_PATH environment variable
> >> No package 'gtk-sharp' found
> >
> >> when I echo $PKG_CONFIG_PATH I get
> >> /usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/opt/gnome/lib/pkgconfig:/usr/lib:/usr
> >>
> >> looking in /usr/lib/pkgconfig folder I see
> >> gtk-sharp-2.0.pc but not gtk-sharp.pc
> >
> > I actually just created a symlink and it worked happily for me.
> >
> > To be honest, I thought that problem had been fixed by now.
> It is not a "problem" dude. The 1.0 and 2.0 gtk sharp's are || installable.
> By creating a symlink, you risk using the 2.0 methods in an assembly that
> is targeted at 1.0 people.
> -- Ben
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list
Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com

joe_audette at yahoo.com
Do you Yahoo!?
 Yahoo! Search presents - Jib Jab's 'Second Term'
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20050208/157f2fe6/attachment.html 

More information about the Mono-devel-list mailing list