[Mono-devel-list] Can't build monodoc from svn

Paul paul at all-the-johnsons.co.uk
Tue Feb 8 02:32:34 EST 2005


> I'm getting this error when I run 
> ./autogen.sh --prefix=/usr
> checking for gtk-sharp >= 0.91 gtkhtml-sharp >= 0.91
> glade-sharp >= 0.91 mono >= 0.90... Package gtk-sharp
> was not found in the pkg-config search path.
> Perhaps you should add the directory containing
> `gtk-sharp.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'gtk-sharp' found

> when I echo $PKG_CONFIG_PATH I get
> /usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/opt/gnome/lib/pkgconfig:/usr/lib:/usr
> looking in /usr/lib/pkgconfig folder I see
> gtk-sharp-2.0.pc but not gtk-sharp.pc

I actually just created a symlink and it worked happily for me.

To be honest, I thought that problem had been fixed by now.


"I don't know how World War III will be fought, but I do know World War
IV will be fought with sticks and stones" - Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20050208/9b701b8e/attachment.bin 

More information about the Mono-devel-list mailing list