[Mono-devel-list] I still Can't Build gtk-sharp from svn

Joe Audette joe_audette at yahoo.com
Sun Feb 6 18:30:01 EST 2005

I would really appreciate if someone can help me past
this error trying to build gtk-sharp from svn

I built mono, xsp, mod_mono and all work fine.

for gtk-sharp, when I run ./autogen.sh --prefix=/usr
the output is:

Optional assemblies included in the build:

      * art-sharp.dll: yes
      * gnomevfs-sharp.dll: yes
      * gnome-sharp.dll: yes
      * glade-sharp.dll: yes
      * gda-sharp.dll: yes
      * gnomedb-sharp.dll: yes
      * rsvg-sharp.dll: yes
      * gtkhtml-sharp.dll: yes
      * vte-sharp.dll: yes
      * gtk-dotnet.dll: yes

When I run make I end up with this error:

grep: /usr/lib/libesd.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/libesd.la: No such
file or directory
libtool: link: `/usr/lib/libesd.la' is not a valid
libtool archive
make[3]: *** [libgnomesharpglue-2.la] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/mono/gtk-sharp'
make: *** [all] Error 2
linux:/usr/src/mono/gtk-sharp #

I'm using Suse 9.2 on a P3 850MHz
Any help would be greatly appreciated.

Joe Audette

Do you Yahoo!? 
Yahoo! Mail - 250MB free storage. Do more. Manage less. 

More information about the Mono-devel-list mailing list