[Mono-devel-list] WebRequest problem

Kevin B. db at ke5in.com
Fri Feb 4 15:51:41 EST 2005

Hi Guys,

Yesterday I posted this question on Mono-list but got no response there;
perhaps my query is better posted here.

I think there is a problem with the WebRequest class or at least with the
way I am using it.

The thing that makes me believe there is a problem with WebRequest is that
this app will run fine when I compile and run it in Windows on .NET 1.1

In Mono 1.0.5 on fc2 I am able to make two successful web requests but
each request after will give me a time out.  Since the problem is not
intermittent (it always happens right on the third request)  I do not
believe it is my internet connection (also the code works fine running in

Attached is a tiny console app that reproduces the problem.  (I’ve greatly
reduced the amount of code from when I posted it yesterday on the other

When I run the app on fc2 I get this for output:

Trying to get: Y
Y: No exception occurred

Trying to get: CAT
CAT: No exception occurred

Trying to get: ITW
Exception Occurred: The operation has timed-out.

Trying to get: MKL
Exception Occurred: The operation has timed-out.

Trying to get: DGII
Exception Occurred: The operation has timed-out.

. . . and so on . . .

Under .NET I will not get any time outs.  I tried increasing the time out
period but that did not help.  Also, I believe I am releasing all
resources before I exit the GetURL method.

Any thoughts would be greatly appreciated.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Class1.cs
Url: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20050204/b0764fe8/attachment.pl 

More information about the Mono-devel-list mailing list