[Mono-devel-list] mod-mono trouble on debian

Oliver Weichhold oliver at weichhold.com
Fri Aug 5 09:31:00 EDT 2005


I'm experiencing trouble getting mod-mono to run on one of my debian
boxes. The same configuration runs fine on my other testing machine. Both
machines had older 1.02 versions of mono installed which have been
compiled from source. I've tried my best to get rid of all older files
before installing the debian packages.

This is my mono package configuration:

[root at orion /etc/mono-server]$ apt-show-versions -r -p mono
mono-assemblies-base/testing uptodate
mono-apache-server/unknown uptodate 1.0.5-0pre2
mono-jit/testing uptodate
mono-mcs/testing uptodate
mono-common/testing uptodate
libapache-mod-mono/unknown uptodate 1.0.5-0pre1
mono not installed
mono-classlib-1.0/testing uptodate

Note: libapache-mod-mono ist pulled from http://debian.pablo.com.mx. The
rest from debian/testing. I've also tried libapache-mod-mono 1.0.1 from
unstable but it didn't work at all.

When I run my very simple asp.net test application which basically does
nothing but setting a label to the value of a testbox on postback I'm
getting the following error output:

Server error in '/aspxtest' application


Data length is shorter than Content-Length.
Description: Error processing request.
Error Message: HTTP 400. Data length is shorter than Content-Length.

Any help would be extremely appreciated.

More information about the Mono-devel-list mailing list