[Mono-devel-list] ConnectError while using XSP/mod-mono

Mike McKay mike at vdomck.org
Tue Sep 7 17:48:45 EDT 2004

Gonzalo Paniagua Javier wrote:
> On Mon, 2004-09-06 at 09:34, Mike McKay wrote:
>>All of the sudden my mod-mono installation stopped working, and now I 
>>can't even get xsp to work. I have a really simple asmx in it's own 
> [...]
>>The web service returned the following result:
>>Error: ConnectFailure
>>Are there any logs or debug info that can help me get to the bottom of 
>>this? Is this something non-mono related?
> you can see the apache error log for more information. Anyway, if it
> worked before and it does not now, you probably updated something in
> your system that affected apache or mono.

Okay, so I had it working this afternoon, but I came home and now it 
isn't working again. The error log shows nothing when I try and execute 
the HelloWorld web service. I am still getting ConnectFailure.

On a whim, I just tried changing the URL to be the hostname instead of 
the domain. That worked. My domain name is a dyndns account, and there 
is some host file hacking keeping my duct tape and baling wire system 
going. Something somewhere is out of sync. At any rate, thanks for the 
help, the problem is squarely mine, but perhaps the ConnectFailure 
message could be bolstered with some information about what is trying to 
be connected.


More information about the Mono-devel-list mailing list