[Mono-devel-list] Language Shootout - problems with Mono times

Isaac Gouy igouy2 at yahoo.com
Wed Sep 1 14:06:28 EDT 2004

--- Paolo Molaro <lupus at ximian.com> wrote: 
> > Are we talking about the 'helper process'? 
> I tried by running a separate mono (which just sits there waiting fro
> a keystroke) so the helper process is not run when executing sieve, 
> but it makes no difference.

Yes, I tried a similar test after finding out about the 'helper
process' ;-)

> > What do you mean by "mono's usage of threads"?
> The only thing that comes to mind is that mono executes code in a
> subthread, not in the thread that executes main(). A quick pthread
> test shows that time behaves correctly in this case, though, so it
> be something else that confuses the kernel.


> > My ancient Linux 2.4.19 Gentoo gives both sensible results and too
> > small  results. (Not sure which version the other guys are using.)
> Kernel 2.2.20 has the same behaviour: sometimes the results are
> correct and sometimes not.

Beyond me. Do you know of anyone who might be interested in looking at
this issue?

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Mono-devel-list mailing list