[Mono-devel-list] Trouble building Mono from cvs

Benjamin Joldersma ben at joldersma.org
Tue Oct 26 14:32:34 EDT 2004

Hello everyone,

I'm new to mono - been developing with ms.net for a couple years now.  I 
*really* want to build a new project in the linux/mono/open source 
space.  I am very impressed with what you all have accomplished.  Some 
initial asp.net pages I've written execute quite speedily.

However, I'm at a point (trying to fix an issue with Gentle.net, 
http://www.mertner.com/confluence/ that breaks it with the 1.0+ build of 
mono), that I really need a working debugger.  I've seen some posts 
around talking about the importance of this - I'm sure you're all 
familiar with them.  Well, here's one more vote on the record :)

That said, I'm perfectly happy with using whatever functionality is 
there, and filing bugs, perhaps even fixing something obvious and easy 
and submitting a patch.  But, I can't seem to compile the version of 
mono I checked out from cvs.  I checked it out yesterday (maybe two days 
ago, to be honest.)  I

I'm using Automake 1.8.5, Autoconf 2.10, Gentoo Linux 1.4, kernel 
2.6.9.  I'm on a gateway 200xl centrino laptop.  I have Gnome, Gtk2, 
pkg-config (I think its installed?).  I've emerged the mono package 
(1.02-r1).  I've "recharged" with the 10-26 versions of mono, 
monocharge, and monolite. I've also tried compiling with a few other 
versions of automake and autoconf.  I've deleted the cvs folders and 
re-checked them out numerous times.  I've also tried changing the prefix 
from /usr to a non-standard directory, to avoid conflicts.

I can get mcs to compile, pretty easily now.  But mono is breaking 
pretty consistently at this point (I'm copying a few lines to give context.)

In file included from ../../mono/io-layer/handles-private.h:16,
                 from daemon.c:30:
../../mono/io-layer/wapi-private.h:32:2: #error configure failed to 
discover size of unix socket path
In file included from ../../mono/io-layer/thread-private.h:16,
                 from ../../mono/io-layer/wapi-private.h:106,
                 from ../../mono/io-layer/handles-private.h:16,
                 from daemon.c:30:
../../mono/io-layer/timed-thread.h:29: error: syntax error before 
../../mono/io-layer/timed-thread.h:29: warning: type defaults to `int' 
in declaration of `MonoSemType'
../../mono/io-layer/timed-thread.h:29: warning: data definition has no 
type or storage class
../../mono/io-layer/timed-thread.h:45: error: syntax error before 
../../mono/io-layer/timed-thread.h:45: warning: no semicolon at end of 
struct or union
../../mono/io-layer/timed-thread.h:46: warning: type defaults to `int' 
in declaration of `suspended_sem'

Any help would be greatly greatly appreciated - I am extremely eager to 
get my feet wet in my project in this environment.

take care,

--ben joldersma

More information about the Mono-devel-list mailing list