[Mono-devel-list] Beta 1 Solaris 8 Build Issue

Sandy Dunlop sandy at sorn.net
Wed May 12 18:05:53 EDT 2004

On Monday 10 May 2004 19:37, Chris Alton wrote:
> Interesting. I was talking to Bernie Solomon about this issue too and we
> were looking at the libraries it was referencing and it seems that the
> -lsockets has the functions in it as well. Do you think that since both
> xnet and sockets are being used that they could be conflicting in some way?
> I tried this with both GCC 3.3.1 and the Sun ld and then with GCC 3.4.0 and
> the GNU ld. They both gave me the same error. Did you do anything unusual
> when you compiled?

I built Mono (mcs) again today on Solaris 9 (sparc) with GCC 3.3.2, and had no 
problems. It was simply a matter of typing ./configure and make. There was no 
tweaking required.

Linking a program with -lnsl and -lsocket together on Solaris is the normal 
way to do things, and will not cause any conflicts. Not sure if it makes a 
difference with shared objects (it does when statically linking), but try 
editing the Makefile so that -lnsl appears before -lsocket.

I'm not sure about xnet - can't remember off the top of my head what it 
provides, and it's a bit too late at night to power up the noisy Sparc 5 at 
home to find out :-)

More information about the Mono-devel-list mailing list