[Mono-devel-list] Mono on Mac OS X [Working]

Herr Witten lingwitt at bellsouth.net
Mon Jun 7 00:49:43 EDT 2004

You have to add /sw/lib to DYLD_LIBRARY_PATH

On 7 Jun 2004, at 0:46, Herr Witten wrote:

> To install mono 0.95, I had to do some weird things with .dlls. I 
> believe I did the following:
> 1. Install the latest fink and set it for unstable packages by adding 
> the following to the "Trees" field of /sw/etc/fink.conf:
> 		 unstable/main unstable/crypto
> 2. I installed mono from fink and then removed it to leave the 
> dependencies.
> 3. I downloaded the mono source from cvs:
> cvs -d:pserver:anonymous at anoncvs.go-mono.com:/mono login
> cvs -d:pserver:anonymous at anoncvs.go-mono.com:/mono co gtk-sharp
> cvs -d:pserver:anonymous at anoncvs.go-mono.com:/mono co mcs
> cvs -d:pserver:anonymous at anoncvs.go-mono.com:/mono co mono
> 4. I already had gc and icu installed, but I don't think 0.95 used 
> them since I built it with:
> 	./configure
> 	make
> 	sudo make install
> 5. During the make, I got a bunch of nonsense saying that certain dll 
> couldn't be found. I downloaded the monocharge from 
> http://www.go-mono.com/daily/ to get all of the .dlls and .exes. I 
> then put them into the directory that the make process was looking it
> pathToSource/mcs/class/lib/default
> and
> pathToSource/mcs/class/lib/net_2_0
> 6. I then ran make and it worked, so I ran
> 	sudo make install
> 7. mcs could not read the installed mcs.exe file in 
> /usr/local/lib/mono/1.0, so I replaced it with the monocharge version.
> 8. It worked.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 1645 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20040607/3d8873b5/attachment.bin 

More information about the Mono-devel-list mailing list