[Mono-devel-list] Threading, NPTL, libgc (beta2)

Mike Morano mmorano at mikeandwan.us
Fri Jun 4 23:23:02 EDT 2004

Hi Peter,
  I think I am in the same boat as you.  Since upgrading to beta2, I have been 
running into odd behavior w/ XSP and mod_mono (and I also run gentoo).  I 
sent a note to the mono user list about this, but haven't heard anything yet.  
I tried upgrading to the latest available glibc, and still have the same 
problems.  I might try to play around with some things this weekend, but I am 
not hopeful...

  Are there any happy Gentoo folks that aren't having this odd behavior in 
beta2? (then we can compare the packages we each have installed..)


On Friday 04 June 2004 10:06 pm, Peter Johanson wrote:
> On Fri, Jun 04, 2004 at 02:39:25PM -0400, Peter Johanson wrote:
> > hey all,
> >
> > After upgrading to beta2, I've started running into some very erratic
> > behavior from blam and muine. In particular with blam, I was getting
> > frequent hangs. After struggling with trying to pinpoint things a bit, i
> > tried exporting GC_DONT_GC, and lo and behold, blam worked *perfectly*.
> > Muine is randomly segfaulting on me, and unfortunately disabling GC
> > didn't fix that. BUT, i noticed that with a non-NPTL glibc, blam was
> > having fewer/no issues.
> >
> > So, my current guess is the libgc update that happened from beta1->beta2
> > has had a subtle and nefarious change that is causing at least some
> > breakage. This level of debugging is a bit beyond me, but I'm more than
> > willing to help out if pointed in the right direction for where to start
> > looking. I'm not really sure what all debugging info you'd like, so
> > simply respond and ask, and I'll provide. Thanks a gazillion in advance.
> >
> > -pete
> >
> > PS - System is a Gentoo box with gcc-3.3.2 (-r5) and glibc-2.3.2 (-r10)
> > with NPTL support.
> responding to myself:
> From discussion in #muine, it seems that *only* gentoo users are having
> this problem. It only started as of beta2 (beta1 worked like a charm).
> It's clearly some some subtle discrepancy in base stuff
> (glibc/gcc/lord-knows) that has only know been exposed by some changes
> in mono as of beta2. I've got no chance of solving this with my
> (basically) utter lack of knowledge of these low level toolchain issues.
> I give up. For now, it seems all gentoo users are screwed. I'm hoping
> that 1.0 official resolves the problems, but i'm not holding my breath.
> If somebody feels like taking a stab at debugging this, let me know,
> i'll happily hand out passwords and logins.
> -pete
> > --
> > Peter Johanson
> > <latexer at gentoo.org>
> >
> > Key ID = 0x6EFA3917
> > Key fingerprint = A90A 2518 57B1 9D20 9B71  A2FF 8649 439B 6EFA 3917

More information about the Mono-devel-list mailing list