[Mono-devel-list] Threading, NPTL, libgc (beta2)

Peter Johanson latexer at gentoo.org
Fri Jun 4 14:39:25 EDT 2004

hey all,

After upgrading to beta2, I've started running into some very erratic
behavior from blam and muine. In particular with blam, I was getting
frequent hangs. After struggling with trying to pinpoint things a bit, i
tried exporting GC_DONT_GC, and lo and behold, blam worked *perfectly*.
Muine is randomly segfaulting on me, and unfortunately disabling GC
didn't fix that. BUT, i noticed that with a non-NPTL glibc, blam was
having fewer/no issues.

So, my current guess is the libgc update that happened from beta1->beta2
has had a subtle and nefarious change that is causing at least some
breakage. This level of debugging is a bit beyond me, but I'm more than
willing to help out if pointed in the right direction for where to start
looking. I'm not really sure what all debugging info you'd like, so
simply respond and ask, and I'll provide. Thanks a gazillion in advance.


PS - System is a Gentoo box with gcc-3.3.2 (-r5) and glibc-2.3.2 (-r10)
with NPTL support.
Peter Johanson
<latexer at gentoo.org>

Key ID = 0x6EFA3917
Key fingerprint = A90A 2518 57B1 9D20 9B71  A2FF 8649 439B 6EFA 3917
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20040604/910793d0/attachment.bin 

More information about the Mono-devel-list mailing list