[Mono-devel-list] Problem compiling Mono with ICU support

Joe Scaduto scooch at noggle.biz
Tue Jan 6 16:33:45 EST 2004

I just installed ICU under /usr/local and everything went well and i ran
./configure --prefix=/usr/local on mono-0.29 and it recognized ICU
version 2.6.1.  My problem is when I ran make I get this error:

./genmdesc ./cpu-pentium.md cpu-pentium.h pentium_desc
./genmdesc: error while loading shared libraries: libicui18n.so.26:
cannot open shared object file: No such file or directory
make[3]: *** [cpu-pentium.h] Error 127
make[3]: Leaving directory `/usr/local/Mono/src/mono/mono/mini'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/Mono/src/mono/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/Mono/src/mono'
make: *** [all] Error 2

I went into /usr/local/lib and the and found the file......? Not quite
sure what is happening here. Any help would be great.  


More information about the Mono-devel-list mailing list