[Mono-devel-list] Problems compiling mini in glibc 2.3.3 (TLS)

Bruno Fernandez-Ruiz brunofr at olympum.com
Mon Feb 23 16:04:40 EST 2004

On Sat, 2004-02-21 at 19:36, Paolo Molaro wrote:
> On 02/21/04 Bruno Fernandez-Ruiz wrote:
> > In mono CVS, as well as in all mono daily tarballs since 02/17 I am
> > getting an error with TLS while compiling mini:
> [...]
> > ./.libs/libmono.so: undefined reference to `___tls_get_addr'
> > 
> > My system:
> > Linux localhost 2.6.3-rc3-gentoo #1 SMP Mon Feb 16 22:16:17 EET 2004
> > i686 Intel(R) Pentium(R) 4 CPU 2.66GHz GenuineIntel GNU/Linux
> > Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.3/specs
> It looks like the gentoo toolchain (gcc and libc combination) are
> miscompiled and they don't support the use of __thread vars in shared
> libraries. Please report the bug to their maintainers. In the mean time
> you can workaround by compiling mono with the --without-nptl configure
> option.

Fyi, the --without-nptl switch worked fine. I also tried by adding nptl
support to my glibc build (USE=-nptl) and was able to compile mono
configured --with-nptl. 

I have attached a simple test library using __thread to bugzilla: 

and shown the error I get when not TLS support is available.

Thanks for the help.

Bruno Fernandez-Ruiz <brunofr at olympum.com>
The Olympum Group,  http://www.olympum.com

More information about the Mono-devel-list mailing list