[Mono-devel-list] ** ERROR **: file appdomain.c: line 898 (ves_icall_System_AppDoma in_LoadAssembly): assetion failed: (assRef != NULL), aborting...

Urs Muff umuff at QUARK.com
Mon Feb 9 14:41:54 EST 2004

I tried AppDomain.CurrentDomain.Load, Assembly.Load, Assembly.LoadFile, and
Assembly.LoadWithPartialName.  I always get the same error.

I don't know which reference cannot be loaded, but all references are either
in the same directory as the assembly to be loaded, or system assemblies.

I'm also adding a AssemblyResolve handler (which is not called).

Please advice: what parts are supported on mono?  [BTW: this code is running
fine on .Net 1.1].
This is a showstopper for me: I can't get further without a workaround or

- Urs C. Muff
Software Architect		- Research Lab
Quark Inc.
UMuff at Quark.Com    	- X6360
+1 (303) 894 3360
This e-mail transmission and any documents, files, or previous e-mail
messages appended or attached to it, may contain information that is
confidential or legally privileged. If you are not the intended recipient,
or a person responsible for delivering it to the intended recipient, you are
hereby notified that you must not read this transmission and that any
disclosure, copying, printing, distribution, or use of the information
contained or attached to this transmission is STRICTLY PROHIBITED. If you
have received this transmission in error, please immediately notify the
sender by telephone +1 (303) 894-3360 or return e-mail message
umuff at quark.com <mailto:umuff at quark.com>  and delete the original
transmission, its attachments, and any copies without reading or saving in
any manner. Thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20040209/82f0b2bd/attachment.html 

More information about the Mono-devel-list mailing list