[Mono-devel-list] mono hangs with differrent applications

Christian Krause chkr at plauener.de
Sat Dec 18 18:55:55 EST 2004


I have the following problem with mono for a long time and now I want to
track i down definitly. ;-)

Nearly every mono program I tried hangs sometimes. The mono process just
doing nothing. E.g. appdomain2.exe from mono/tests:

$ ps aHwwwx
28631 pts/9    S+     0:00 perl ./test-driver ../mini/mono appdomain2.exe  --config tests-config --optimize=all
28632 pts/9    S+     0:00 sh -c ../mini/mono --config tests-config --optimize=all appdomain2.exe 2>/dev/null 1>appdomain2.exe.stdout
28633 pts/9    Sl+    0:00 /usr/src/RPM/BUILD/mono-1.0.5/mono/mini/.libs/lt-mono --config tests-config --optimize=all appdomain2.exe
28633 pts/9    Sl+    0:00 /usr/src/RPM/BUILD/mono-1.0.5/mono/mini/.libs/lt-mono --config tests-config --optimize=all appdomain2.exe
28646 ?        Ss     0:00 /usr/src/RPM/BUILD/mono-1.0.5/mono/mini/.libs/lt-mono --config tests-config --optimize=all appdomain2.exe

$ strace -p 28646
Process 28646 attached - interrupt to quit
poll( <unfinished ...>

$ strace -p 28633
Process 28633 attached - interrupt to quit
write(2, "Sem_wait returned -1\n", 21)  = 21
write(2, "sem_wait for handler failed\n", 28) = 28
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(28633, 28633, SIGABRT)           = 0
--- SIGABRT (Aborted) @ 0 (0) ---
Process 28633 detached

The appdomain2 test failed after tracing 28633:

	failed 34304 (134) signal (0).

For this special problem I filed a bug report a week ago, but no response

Because this bug occurs with different applications (beagle, muine, ...) 
and it occurs with ntpl and pthreads as well, I want to take some action
to solve the problem.

It seems, that this bug occurs much often on SMP systems (e.g. P4 with

I want to ask the developers of mono how the problem could be solved. I
want to help as much as I can, but for now I don't have any ideas.

Thanks in advance,

More information about the Mono-devel-list mailing list